about summary refs log tree commit diff stats
path: root/modules/by-name/do/documentation/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/do/documentation/module.nix')
-rw-r--r--modules/by-name/do/documentation/module.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/by-name/do/documentation/module.nix b/modules/by-name/do/documentation/module.nix
new file mode 100644
index 00000000..4616a991
--- /dev/null
+++ b/modules/by-name/do/documentation/module.nix
@@ -0,0 +1,25 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.documentation;
+in {
+  options.soispha.documentation = {
+    enable = lib.mkEnableOption "documentation";
+  };
+  config = lib.mkIf cfg.enable {
+    documentation = {
+      nixos = {
+        # FIXME: This results in a evaluation failure (with lanzaboote options) <2024-05-23>
+        includeAllModules = false;
+
+        enable = true;
+      };
+      dev = {
+        # Add man pages aimed at developers (I guess c library stuff, and the like)
+        enable = true;
+      };
+    };
+  };
+}