about summary refs log tree commit diff stats
path: root/modules/by-name/do/documentation/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/by-name/do/documentation/module.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/by-name/do/documentation/module.nix')
-rw-r--r--modules/by-name/do/documentation/module.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/by-name/do/documentation/module.nix b/modules/by-name/do/documentation/module.nix
new file mode 100644
index 00000000..4616a991
--- /dev/null
+++ b/modules/by-name/do/documentation/module.nix
@@ -0,0 +1,25 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.documentation;
+in {
+  options.soispha.documentation = {
+    enable = lib.mkEnableOption "documentation";
+  };
+  config = lib.mkIf cfg.enable {
+    documentation = {
+      nixos = {
+        # FIXME: This results in a evaluation failure (with lanzaboote options) <2024-05-23>
+        includeAllModules = false;
+
+        enable = true;
+      };
+      dev = {
+        # Add man pages aimed at developers (I guess c library stuff, and the like)
+        enable = true;
+      };
+    };
+  };
+}