about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index ba1b8e3a..be0376f0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -245,6 +245,12 @@
       url = "github:arkenfox/user.js";
       flake = false;
     };
+    treefmt-nix = {
+      url = "github:numtide/treefmt-nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
   };
 
   outputs = {
@@ -263,6 +269,7 @@
     nixVim,
     # external dependencies
     user_js,
+    treefmt-nix,
     templates,
     # my binaries
     video_pause,
@@ -305,6 +312,7 @@
         lanzaboote
         # external dependencies
         
+        treefmt-nix
         user_js
         templates
         # my binaries