about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-02-20 15:34:03 +0100
committerSoispha <soispha@vhack.eu>2024-02-20 15:49:47 +0100
commit7d7bb4838feba557fc4f8ad022f734d7db273943 (patch)
tree1d2ead8241a7e292d89bfb7d0f74e9f26edefbe4 /flake.nix
parentfix(hm/conf/nix/plgs/lsp/s/openscad): GNU is unfortunately not the best format (diff)
downloadnixos-config-7d7bb4838feba557fc4f8ad022f734d7db273943.tar.gz
nixos-config-7d7bb4838feba557fc4f8ad022f734d7db273943.zip
build(flake): Add treefmt
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index ba1b8e3a..be0376f0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -245,6 +245,12 @@
       url = "github:arkenfox/user.js";
       flake = false;
     };
+    treefmt-nix = {
+      url = "github:numtide/treefmt-nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
   };
 
   outputs = {
@@ -263,6 +269,7 @@
     nixVim,
     # external dependencies
     user_js,
+    treefmt-nix,
     templates,
     # my binaries
     video_pause,
@@ -305,6 +312,7 @@
         lanzaboote
         # external dependencies
         
+        treefmt-nix
         user_js
         templates
         # my binaries