about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index a75f9604..836c6d8e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,7 +4,7 @@
   inputs = {
     # base
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
-    nixpkgs-stable-release.url = "github:NixOS/nixpkgs/nixos-23.05";
+    nixpkgs_stable_release.url = "github:NixOS/nixpkgs/nixos-23.05";
 
     # inputs for following
     systems = {
@@ -88,12 +88,13 @@
       };
     };
     lanzaboote = {
-      url = "github:nix-community/lanzaboote";
-
+      url = "github:nix-community/lanzaboote/v0.3.0";
       inputs = {
+        nixpkgs.follows = "nixpkgs_stable_release";
         flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
-        nixpkgs.follows = "nixpkgs-stable-release";
+        crane.follows = "crane";
+        rust-overlay.follows = "rust-overlay";
       };
     };