about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-23 08:37:20 +0200
committerSoispha <soispha@vhack.eu>2023-07-23 08:37:20 +0200
commit1566fcf695101c4fc1c05e3ba25cb4ee5d9c9911 (patch)
treebbc66a668f341190ec2900082d4ff61a1386ffaf /flake.nix
parentBuild(flake): Update (diff)
downloadnixos-config-1566fcf695101c4fc1c05e3ba25cb4ee5d9c9911.tar.gz
nixos-config-1566fcf695101c4fc1c05e3ba25cb4ee5d9c9911.zip
Build(flake): Switch to stable lanzaboote to sidestep building llvm/rustc
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index a75f9604..836c6d8e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,7 +4,7 @@
   inputs = {
     # base
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
-    nixpkgs-stable-release.url = "github:NixOS/nixpkgs/nixos-23.05";
+    nixpkgs_stable_release.url = "github:NixOS/nixpkgs/nixos-23.05";
 
     # inputs for following
     systems = {
@@ -88,12 +88,13 @@
       };
     };
     lanzaboote = {
-      url = "github:nix-community/lanzaboote";
-
+      url = "github:nix-community/lanzaboote/v0.3.0";
       inputs = {
+        nixpkgs.follows = "nixpkgs_stable_release";
         flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
-        nixpkgs.follows = "nixpkgs-stable-release";
+        crane.follows = "crane";
+        rust-overlay.follows = "rust-overlay";
       };
     };