about summary refs log tree commit diff stats
path: root/pkgs/sources/yt/Cargo.toml
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
commit204731c0a69136c9cebcb54f1afecf5145e26bbe (patch)
treefc9132e5dc74e4a8e1327cdd411839a90f9410aa /pkgs/sources/yt/Cargo.toml
parentrefactor(sys): Modularize and move to `modules/system` or `pkgs` (diff)
downloadnixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.tar.gz
nixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.zip
refactor(pkgs): Categorize into `by-name` shards
This might not be the perfect way to organize a package set --
especially if the set is not nearly the size of nixpkgs -- but it is
_at_ least a way of organization.
Diffstat (limited to 'pkgs/sources/yt/Cargo.toml')
-rw-r--r--pkgs/sources/yt/Cargo.toml35
1 files changed, 0 insertions, 35 deletions
diff --git a/pkgs/sources/yt/Cargo.toml b/pkgs/sources/yt/Cargo.toml
deleted file mode 100644
index 7c17d20b..00000000
--- a/pkgs/sources/yt/Cargo.toml
+++ /dev/null
@@ -1,35 +0,0 @@
-[package]
-name = "yt"
-version = "0.1.0"
-edition = "2021"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
-anyhow = "1.0.83"
-clap = { version = "4.5.4", features = ["derive"] }
-cli-log = "2.0.0"
-log = "0.4.21"
-serde = { version = "1.0.201", features = ["derive"] }
-serde_json = "1.0.117"
-tempfile = "3.10.1"
-url = "2.5.0"
-
-# This is here to be able to tell nix which binary to build
-[features]
-yts = []
-ytc = []
-yt = []
-default = ["yt", "yts", "ytc"]
-
-[[bin]]
-name = "yts"
-required-features = ["yts"]
-
-[[bin]]
-name = "ytc"
-required-features = ["ytc"]
-
-[[bin]]
-name = "yt"
-required-features = ["yt"]