about summary refs log tree commit diff stats
path: root/pkgs/sources/yt/Cargo.toml
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:10:21 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:14:26 +0200
commit368cb6b0d25db2ae23be42ad51584de059997e51 (patch)
tree3282e45d3ebced63c8498a47e83a255c35de620b /pkgs/sources/yt/Cargo.toml
parentrefactor(hm): Rename to `modules/home` (diff)
downloadnixos-config-368cb6b0d25db2ae23be42ad51584de059997e51.tar.gz
nixos-config-368cb6b0d25db2ae23be42ad51584de059997e51.zip
refactor(sys): Modularize and move to `modules/system` or `pkgs`
Diffstat (limited to 'pkgs/sources/yt/Cargo.toml')
-rw-r--r--pkgs/sources/yt/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/sources/yt/Cargo.toml b/pkgs/sources/yt/Cargo.toml
new file mode 100644
index 00000000..7c17d20b
--- /dev/null
+++ b/pkgs/sources/yt/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "yt"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.83"
+clap = { version = "4.5.4", features = ["derive"] }
+cli-log = "2.0.0"
+log = "0.4.21"
+serde = { version = "1.0.201", features = ["derive"] }
+serde_json = "1.0.117"
+tempfile = "3.10.1"
+url = "2.5.0"
+
+# This is here to be able to tell nix which binary to build
+[features]
+yts = []
+ytc = []
+yt = []
+default = ["yt", "yts", "ytc"]
+
+[[bin]]
+name = "yts"
+required-features = ["yts"]
+
+[[bin]]
+name = "ytc"
+required-features = ["ytc"]
+
+[[bin]]
+name = "yt"
+required-features = ["yt"]