about summary refs log tree commit diff stats
path: root/lib/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-03-21 16:57:48 +0100
committerene <ene@sils.li>2023-03-21 16:57:48 +0100
commitc57d891d0523bfacd3ec9a4d50e7c6fc53dfd674 (patch)
treedb13bd2a57151918b7381e843c1f5fe0282685fd /lib/default.nix
parentStyle(bootstrap/install): Improve the msg output (diff)
downloadnixos-config-c57d891d0523bfacd3ec9a4d50e7c6fc53dfd674.tar.gz
nixos-config-c57d891d0523bfacd3ec9a4d50e7c6fc53dfd674.zip
Fix(lib): Add 'dash' as default dependency
This is also fine because dash is used as the interpreter for shell
scripts.
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 38301ea0..f368121a 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -4,7 +4,7 @@
   ...
 }: let
   shellLibraryDeps =
-    builtins.attrValues {inherit (pkgs) mktemp;};
+    builtins.attrValues {inherit (pkgs) mktemp dash;};
 in {
   makeShellScriptWithLibrary = {
     dependencies,