about summary refs log tree commit diff stats
path: root/flake/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-02-24 14:59:50 +0100
committerSoispha <soispha@vhack.eu>2024-02-24 15:04:49 +0100
commit8284b6a7b4d212913083b003a819fda8d4931d4d (patch)
tree1a41cb60fe64f3f9b1a8c33bd2895ad419366cb5 /flake/default.nix
parentfix(hm/pkgs/git-update-index): Remove '--' from help text (diff)
downloadnixos-config-8284b6a7b4d212913083b003a819fda8d4931d4d.tar.gz
nixos-config-8284b6a7b4d212913083b003a819fda8d4931d4d.zip
refactor(hm/pkgs): Implement with an nixpkgs overlay
Diffstat (limited to 'flake/default.nix')
-rw-r--r--flake/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/flake/default.nix b/flake/default.nix
index bbf9044e..185286eb 100644
--- a/flake/default.nix
+++ b/flake/default.nix
@@ -140,7 +140,7 @@
       };
     }
   );
-in {
+
   nixosConfigurations = import ./nixosConfigurations {
     inherit
       system
@@ -152,7 +152,8 @@ in {
       defaultSpecialArgs
       ;
   };
-  inherit pkgs;
+in {
+  inherit pkgs nixosConfigurations;
   checks."${system}" = {
     inherit
       (self.packages."${system}")