about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..dfb50da
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,17 @@
+# vim: ts=2
+{
+  description = "A collection of nix flake templates for diffrent languages";
+
+  outputs = {self}: {
+    templates.rust = {
+      path = ./rust;
+      description = "A simple Rust/Cargo project";
+      welcomeText = "";
+    };
+    templates.rustToolchain = {
+      path = ./rust/toolchain.nix;
+      description = "A simple Rust/Cargo project with a diffrent toolchain";
+      welcomeText = "";
+    };
+  };
+}