about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-27 16:45:31 +0200
committerSoispha <soispha@vhack.eu>2023-05-27 16:45:31 +0200
commitbe36f2c7e68ca0a7f555b24316aaa6340769171d (patch)
treed8137c12f8602c1218f78f47dfaaf21f6b792d43 /flake.nix
downloadflake-templates-be36f2c7e68ca0a7f555b24316aaa6340769171d.tar.gz
flake-templates-be36f2c7e68ca0a7f555b24316aaa6340769171d.zip
Chore: Initial Commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..dfb50da
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,17 @@
+# vim: ts=2
+{
+  description = "A collection of nix flake templates for diffrent languages";
+
+  outputs = {self}: {
+    templates.rust = {
+      path = ./rust;
+      description = "A simple Rust/Cargo project";
+      welcomeText = "";
+    };
+    templates.rustToolchain = {
+      path = ./rust/toolchain.nix;
+      description = "A simple Rust/Cargo project with a diffrent toolchain";
+      welcomeText = "";
+    };
+  };
+}