summary refs log tree commit diff stats
path: root/modules/nixos/roles.nix
diff options
context:
space:
mode:
authorSilas Schöffel <sils@sils.li>2024-10-29 22:11:35 +0100
committerSilas Schöffel <sils@sils.li>2024-10-29 22:11:35 +0100
commit7f29c48e9481d6d4701ce78586e3465260cdd1a1 (patch)
treecbbbc0759b6fc69ca3b4ef23c1df0ac95c5d0062 /modules/nixos/roles.nix
parenthyprland: remove master-layout specification (diff)
downloadnix-config-7f29c48e9481d6d4701ce78586e3465260cdd1a1.tar.gz
nix-config-7f29c48e9481d6d4701ce78586e3465260cdd1a1.zip
roles.sils: add workstation role
Diffstat (limited to 'modules/nixos/roles.nix')
-rw-r--r--modules/nixos/roles.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/nixos/roles.nix b/modules/nixos/roles.nix
index 71883e0..9640bb3 100644
--- a/modules/nixos/roles.nix
+++ b/modules/nixos/roles.nix
@@ -1,6 +1,6 @@
 {lib, ...}: {
   options.role.sils = lib.mkOption {
-    type = lib.types.nullOr (lib.types.enum ["laptop" "undefined" "vm"]);
+    type = lib.types.nullOr (lib.types.enum ["laptop" "undefined" "vm" "workstation"]);
     default = null;
     description = "The role which should be applied to your configuration.";
   };