summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-11-26 17:27:56 +0100
committersils <sils@sils.li>2023-11-26 17:27:56 +0100
commita613d5f92beda47120be703dc328ece09745d8fe (patch)
treefba24e459129d134c22a9721b46fffb7813ac87a /flake.nix
parentfix(flake): optimize imports (diff)
downloadnix-config-a613d5f92beda47120be703dc328ece09745d8fe.tar.gz
nix-config-a613d5f92beda47120be703dc328ece09745d8fe.zip
fix(flake): remove unused imports
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix55
1 files changed, 0 insertions, 55 deletions
diff --git a/flake.nix b/flake.nix
index 02452ee..5c47601 100644
--- a/flake.nix
+++ b/flake.nix
@@ -139,49 +139,6 @@
         flake-utils.follows = "flake-utils";
       };
     };
-
-    shell_library = {
-      url = "git+https://codeberg.org/soispha/shell_library.git";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        flake-utils.follows = "flake-utils";
-        systems.follows = "systems";
-      };
-    };
-    river_init_lesser = {
-      url = "git+https://codeberg.org/soispha/river_keymap_init.git";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        crane.follows = "crane";
-        flake-utils.follows = "flake-utils";
-        rust-overlay.follows = "rust-overlay";
-        flake-compat.follows = "flake-compat";
-      };
-    };
-    yambar_cpu = {
-      url = "git+https://codeberg.org/soispha/yambar_cpu.git";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        crane.follows = "crane";
-        flake-utils.follows = "flake-utils";
-      };
-    };
-    yambar_memory = {
-      url = "git+https://codeberg.org/soispha/yambar_memory.git";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        flake-utils.follows = "flake-utils";
-      };
-    };
-    #grades = {
-    #     url = "git+https://codeberg.org/soispha/grades.git";
-    #     inputs = {
-    #       nixpkgs.follows = "unstable";
-    #       crane.follows = "crane";
-    #       flake-utils.follows = "flake-utils";
-    #       rust-overlay.follows = "rust-overlay";
-    #     };
-    #   };
     prismlauncher = {
       url = "github:PrismLauncher/PrismLauncher";
       inputs = {
@@ -210,11 +167,6 @@
     self,
     nixpkgs,
     home-manager,
-    shell_library,
-    river_init_lesser,
-    yambar_cpu,
-    yambar_memory,
-    #grades,
     prismlauncher,
     lanzaboote,
     nixvim,
@@ -231,7 +183,6 @@
         inherit system;
         overlays = [nixvim.overlays.default];
       };
-      sysLib = shell_library.lib.${system};
       nixVimConfig = import ./users/sils/nixvim/config.nix;
       nvim = nixvim.legacyPackages."${system}".makeNixvim nixVimConfig;
     in {
@@ -264,12 +215,6 @@
           self
           nixpkgs
           home-manager
-          shell_library
-          river_init_lesser
-          yambar_cpu
-          yambar_memory
-          #grades,
-          
           prismlauncher
           lanzaboote
           nixvim