summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-11-26 17:25:25 +0100
committersils <sils@sils.li>2023-11-26 17:25:25 +0100
commitd6806c96ca3fcf88426166f4d973193f8d90f8bf (patch)
tree9358356fe524ba3ab84611bc38a2286f832e2f6c /flake.nix
parentfeat(treewide): remove git-crypt (diff)
downloadnix-config-d6806c96ca3fcf88426166f4d973193f8d90f8bf.tar.gz
nix-config-d6806c96ca3fcf88426166f4d973193f8d90f8bf.zip
fix(flake): optimize imports
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix87
1 files changed, 85 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 58e0738..02452ee 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,6 +4,7 @@
   inputs = {
     nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
     nixpkgs-stable.url = "github:NixOs/nixpkgs/nixos-23.05";
+    nixpkgs-lib.url = "github:NixOs/nixpkgs/nixos-unstable?dir=lib";
 
     home-manager = {
       url = "github:nix-community/home-manager";
@@ -12,10 +13,35 @@
 
     impermanence.url = "github:nix-community/impermanence";
 
+    nix-darwin = {
+      url = "github:lnl7/nix-darwin";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
+    gitignore = {
+      url = "github:hercules-ci/gitignore.nix";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
+    pre-commit-hooks-nix = {
+      url = "github:cachix/pre-commit-hooks.nix";
+      inputs = {
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        gitignore.follows = "gitignore";
+        nixpkgs.follows = "nixpkgs";
+        nixpkgs-stable.follows = "nixpkgs-stable";
+      };
+    };
+
     # inputs for following
     agenix = {
       url = "github:ryantm/agenix";
-      inputs.nixpkgs.follows = "nixpkgs";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        home-manager.follows = "home-manager";
+        darwin.follows = "nix-darwin";
+      };
     };
     ragenix = {
       url = "github:yaxitech/ragenix";
@@ -27,16 +53,54 @@
         crane.follows = "crane";
       };
     };
+    poetry2nix = {
+      url = "github:nix-community/poetry2nix";
+      inputs = {
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+        nix-github-actions.follows = "nix-github-actions";
+        treefmt-nix.follows = "treefmt-nix";
+      };
+    };
+    beautysh = {
+      url = "github:lovesegfault/beautysh";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        poetry2nix.follows = "poetry2nix";
+        utils.follows = "flake-utils";
+      };
+    };
+    nix-github-actions = {
+      url = "github:nix-community/nix-github-actions";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+    treefmt-nix = {
+      url = "github:numtide/treefmt-nix";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
     nixvim = {
       url = "github:nix-community/nixvim";
       inputs = {
         nixpkgs.follows = "nixpkgs";
         flake-utils.follows = "flake-utils";
+        beautysh.follows = "beautysh";
+        pre-commit-hooks.follows = "pre-commit-hooks-nix";
       };
     };
     lanzaboote = {
       url = "github:nix-community/lanzaboote/v0.3.0";
-      inputs.nixpkgs.follows = "nixpkgs";
+      inputs = {
+        crane.follows = "crane";
+        nixpkgs.follows = "nixpkgs";
+        flake-compat.follows = "flake-compat";
+        flake-parts = {
+          follows = "flake-parts";
+          inputs.nixpkgs-lib.follows = "nixpkgs-lib";
+        };
+        flake-utils.follows = "flake-utils";
+        pre-commit-hooks-nix.follows = "pre-commit-hooks-nix";
+        rust-overlay.follows = "rust-overlay";
+      };
     };
     systems = {
       url = "git+https://codeberg.org/sils/systems"; #  specify systems to evaluate
@@ -64,6 +128,10 @@
         systems.follows = "systems";
       };
     };
+    flake-parts = {
+      url = "github:hercules-ci/flake-parts";
+      inputs.nixpkgs-lib.follows = "nixpkgs-lib";
+    };
     rust-overlay = {
       url = "github:oxalica/rust-overlay";
       inputs = {
@@ -116,6 +184,21 @@
     #   };
     prismlauncher = {
       url = "github:PrismLauncher/PrismLauncher";
+      inputs = {
+        flake-compat.follows = "flake-compat";
+        flake-parts.follows = "flake-parts";
+        libnbtplusplus.follows = "libnbtplusplus";
+        nix-filter.follows = "nix-filter";
+        nixpkgs.follows = "nixpkgs";
+        pre-commit-hooks.follows = "pre-commit-hooks-nix";
+      };
+    };
+    nix-filter = {
+      url = "github:numtide/nix-filter";
+    };
+    libnbtplusplus = {
+      url = "github:PrismLauncher/libnbtplusplus";
+      flake = false;
     };
     wl-togglescreens = {
       url = "git+https://git.project-insanity.org/onny/wl-togglescreens.git?ref=main";