summary refs log tree commit diff stats
path: root/tests/nixos/vhack/git-server/test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nixos/vhack/git-server/test.nix')
-rw-r--r--tests/nixos/vhack/git-server/test.nix31
1 files changed, 26 insertions, 5 deletions
diff --git a/tests/nixos/vhack/git-server/test.nix b/tests/nixos/vhack/git-server/test.nix
index 0632483..61a6e02 100644
--- a/tests/nixos/vhack/git-server/test.nix
+++ b/tests/nixos/vhack/git-server/test.nix
@@ -17,6 +17,7 @@
       RW+   = CREATOR
       RW    = WRITERS
       R     = READERS
+      option user-configs = cgit\.owner cgit\.desc cgit\.section cgit\.homepage
   '';
 
   expectedGitoliteConf = pkgs.writeText "expected-gitolite-conf" ''
@@ -30,6 +31,7 @@
      RW+ = CREATOR
      RW = WRITERS
      R = READERS
+     option user-configs = cgit\.owner cgit\.desc cgit\.section cgit\.homepage
   '';
 
   expectedHtmlReadme = pkgs.writeText "expectedHtmlReadme" ''
@@ -80,6 +82,7 @@ in
           };
         };
       };
+
       client = {...}: {
         environment.systemPackages = [pkgs.git];
         programs.ssh.extraConfig = ''
@@ -195,15 +198,33 @@ in
         )
 
       with subtest("Bob can see alice config on cgit"):
-        client.succeed(
-            # Disable ssl verification, as the certs are self-signed
-            "sudo -u bob git -c http.sslVerify=false clone https://server/alice/alice-project.git"
-        )
+        client.succeed("sudo -u bob ${pkgs.writeShellScript "bob-clone-repo" ''
+        set -xe
+
+        cd ~bob
+        # Disable ssl verification, as the certs are self-signed
+        git -c http.sslVerify=false clone https://server/alice/alice-project.git
+      ''}")
+
+      with subtest("Alice can change settings in her repo"):
+        client.succeed("sudo -u alice ${pkgs.writeShellScript "alice-change-settings" ''
+        set -xe
+
+        echo 'Hi! You want to work with alice' | ssh git@server motd alice/alice-project set
+        ssh git@server config alice/alice-project --add 'cgit.owner' 'alice'
+        ssh git@server config alice/alice-project --add 'cgit.section' 'alice'
+        ssh git@server config alice/alice-project --add 'cgit.homepage' 'alice'
+
+        owner="$(ssh git@server config alice/alice-project --get-all 'cgit.owner')"
+        [ "$owner" = "alice" ] || {
+          echo "owner should be alice but is '$owner'!"
+          exit 1
+        }
+      ''}")
 
       client.succeed(
           "curl --insecure --silent --fail --show-error 'https://server/alice/alice-project/about' | diff -u ${expectedHtmlReadme}  -"
       )
-
       # server.succeed(
       #    "git clone http://localhost/%28c%29git/alice-project && diff -u reference/date.txt some-repo/date.txt"
       # )