summary refs log tree commit diff stats
path: root/system/services/redirects/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/redirects/default.nix')
-rw-r--r--system/services/redirects/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/system/services/redirects/default.nix b/system/services/redirects/default.nix
new file mode 100644
index 0000000..0f66e2b
--- /dev/null
+++ b/system/services/redirects/default.nix
@@ -0,0 +1,12 @@
+{...}: {
+  services.nginx = {
+    enable = true;
+    virtualHosts."source.vhack.eu" = {
+      # Redirect all request to the codeberg source
+      locations."/".return = "301 https://codeberg.org/vhack.eu/nixos-server";
+
+      enableACME = true;
+      forceSSL = true;
+    };
+  };
+}