summary refs log tree commit diff stats
path: root/system/services/mastodon/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/mastodon/default.nix')
-rw-r--r--system/services/mastodon/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/system/services/mastodon/default.nix b/system/services/mastodon/default.nix
index efc7335..8e2c174 100644
--- a/system/services/mastodon/default.nix
+++ b/system/services/mastodon/default.nix
@@ -1,5 +1,6 @@
 {
   config,
+  pkgs,
   ...
 }: let
   emailAddress = "mastodon@vhack.eu";
@@ -7,6 +8,10 @@ in {
   services.mastodon = {
     enable = true;
 
+    package = pkgs.mastodon.overrideAttrs (attrs: {
+      patches = (attrs.patches or []) ++ [./patches/mastodon_v4.2.1-maxchar-5000.patch];
+    });
+
     # Unstable Mastodon package, used if
     #security updates aren't backported.
     #package = pkgs-unstable.mastodon;