summary refs log tree commit diff stats
path: root/modules/by-name/ns/nscd/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-12-25 18:23:05 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-12-25 18:23:05 +0100
commit35071eeb107c982925fda3fcef6bbd44940cbb21 (patch)
tree6aee2a170ff0ffb24b4cad9c3f03f3064bb7d925 /modules/by-name/ns/nscd/module.nix
parentdocs(CONTRIBUTING.md): Remove (diff)
downloadnixos-server-35071eeb107c982925fda3fcef6bbd44940cbb21.tar.gz
nixos-server-35071eeb107c982925fda3fcef6bbd44940cbb21.zip
fix(treewide): Add constant uids and gids to each user and group
This allows us to avoid persisting `/var/lib/nixos`.
Diffstat (limited to 'modules/by-name/ns/nscd/module.nix')
-rw-r--r--modules/by-name/ns/nscd/module.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/by-name/ns/nscd/module.nix b/modules/by-name/ns/nscd/module.nix
new file mode 100644
index 0000000..428ae3b
--- /dev/null
+++ b/modules/by-name/ns/nscd/module.nix
@@ -0,0 +1,25 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.vhack.nscd;
+in {
+  options.vhack.nscd = {
+    # NOTE(@bpeetz): This is enabled by default in NixOS.
+    # Because of this reason:
+    # > Whether to enable the Name Service Cache Daemon. Disabling this is
+    # > strongly discouraged, as this effectively disables NSS Lookups from
+    # > all non-glibc NSS modules, including the ones provided by systemd.
+    #
+    # As such we should also always enable it. <2024-12-25>
+    enable = (lib.mkEnableOption "nscd") // {default = true;};
+  };
+
+  config = lib.mkIf cfg.enable {
+    users = {
+      users.nscd.uid = config.vhack.constants.ids.uids.nscd;
+      groups.nscd.gid = config.vhack.constants.ids.gids.nscd;
+    };
+  };
+}