summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-03 15:04:48 +0200
committerSoispha <soispha@vhack.eu>2023-07-05 21:34:07 +0200
commitd176a33b04e9c0254b42850255d2a864f22424e4 (patch)
tree512ddbb90c391d3c6001b03cab87a4efed14e266 /flake.nix
parentStyle(system/fs_layouts): Merge attrsets (diff)
downloadnixos-server-d176a33b04e9c0254b42850255d2a864f22424e4.tar.gz
nixos-server-d176a33b04e9c0254b42850255d2a864f22424e4.zip
Feat(system/disks): Add disko
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index edfb3c4..0cf5609 100644
--- a/flake.nix
+++ b/flake.nix
@@ -11,6 +11,12 @@
     };
 
     # modules
+    disko = {
+      url = "github:nix-community/disko";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
     impermanence = {
       url = "github:nix-community/impermanence";
       inputs = {
@@ -30,6 +36,7 @@
     # modules
     simple-nixos-mailserver,
     impermanence,
+    disko,
     ...
   } @ attrs: let
     system = "x86_64-linux";
@@ -41,6 +48,7 @@
       modules = [
         ./hosts/server1/configuration.nix
         simple-nixos-mailserver.nixosModule
+        disko.nixosModules.default
         impermanence.nixosModules.impermanence
       ];
     };