summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-05 08:58:11 +0100
committerene <ene@sils.li>2023-02-05 09:02:27 +0100
commitcb69f4ae60e2d94039a7bb0b5caa566a9d288686 (patch)
treea428bba3e57539142ac96eeeabbe57af2418055f /flake.nix
parentFlake: Changed the configuration to a flake (diff)
downloadnixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.tar.gz
nixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.zip
Fix: correct host name and convenience changes
We used the domain name instead of the host name, which obviously
doesn't work for multiple host. In addition to that I changed some
directory to make importing easier and enabled the "nix-command" and
"flakes" experimental options, to make the `nix flake check` command
usable.

Refs: #15
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index a6d95b6..2e52203 100644
--- a/flake.nix
+++ b/flake.nix
@@ -11,10 +11,10 @@
     nixpkgs,
     ...
   } @ attrs: {
-    nixosConfigurations."vhack.eu" = nixpkgs.lib.nixosSystem {
+    nixosConfigurations."server1" = nixpkgs.lib.nixosSystem {
       system = "x86_64-linux";
       specialArgs = attrs;
-      modules = [./hosts/vhack.eu/configuration.nix];
+      modules = [./hosts/server1/configuration.nix];
     };
   };
 }