summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-20 12:30:21 +0200
committerSoispha <soispha@vhack.eu>2023-05-20 12:30:21 +0200
commitbb4af299f04604b68e39a907380ed22ef5bd0986 (patch)
tree64f9772a5213866773b566c4c3fa77dc3c380a40 /flake.nix
parentBuild(git-crypt): Add (diff)
downloadnixos-server-bb4af299f04604b68e39a907380ed22ef5bd0986.tar.gz
nixos-server-bb4af299f04604b68e39a907380ed22ef5bd0986.zip
Refactor(system/mail): Hide user emails
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 3baed70..2120778 100644
--- a/flake.nix
+++ b/flake.nix
@@ -44,13 +44,21 @@
         ./hosts/server1/configuration.nix
         simple-nixos-mailserver.nixosModule
         {
-          mailserver = import ./system/mail {};
+          mailserver = import ./system/mail {inherit (pkgs) lib;};
         }
       ];
     };
     devShells."${system}" = {
       default = pkgs.mkShell {
-        packages = with pkgs; [nil alejandra statix shellcheck ltex-ls];
+        packages = with pkgs; [
+          nil
+          alejandra
+          statix
+          shellcheck
+          ltex-ls
+          cocogitto
+          git-crypt
+        ];
       };
     };
   };