summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2024-02-15 20:01:06 +0100
committersils <sils@sils.li>2024-02-15 20:14:52 +0100
commit37f71c496d816aa42f7cf1c7a8924e3914533740 (patch)
tree78e3144ea4a0dd021dc092bf14201bf9a0e8b601 /flake.nix
parentchore(version): v0.23.0 (diff)
downloadnixos-server-37f71c496d816aa42f7cf1c7a8924e3914533740.tar.gz
nixos-server-37f71c496d816aa42f7cf1c7a8924e3914533740.zip
fix: update mastodon
This uses the mastodon package from nixos-unstable-small because
backporting of a security release failed and we can't afford to wait.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 4956365..a8812c8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,6 +3,7 @@
 
   inputs = {
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.11-small";
+    nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixos-unstable-small";
 
     # inputs for following
     systems = {
@@ -77,6 +78,7 @@
   outputs = {
     self,
     nixpkgs,
+    nixpkgs-unstable,
     # modules
     simple-nixos-mailserver,
     impermanence,
@@ -89,10 +91,13 @@
   } @ attrs: let
     system = "x86_64-linux";
     pkgs = nixpkgs.legacyPackages.${system};
+    pkgs-unstable = nixpkgs-unstable.legacyPackages.${system};
   in {
     nixosConfigurations."server1" = nixpkgs.lib.nixosSystem {
       system = "x86_64-linux";
-      specialArgs = attrs;
+      specialArgs = attrs // {
+        inherit pkgs-unstable;
+      };
       modules = [
         ./hosts/server1/configuration.nix
         simple-nixos-mailserver.nixosModule