about summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-04 17:11:19 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-04 17:11:19 +0200
commitbd2b435e7cd782cacfc4c74af3573de7a1791c8e (patch)
treef631881faa69f94b3de3754459f50b1033b3e830 /Cargo.toml
downloadquotify-bd2b435e7cd782cacfc4c74af3573de7a1791c8e.tar.gz
quotify-bd2b435e7cd782cacfc4c74af3573de7a1791c8e.zip
chore: Initial Commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..724f9e5
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,25 @@
+# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
+# SPDX-License-Identifier: AGPL-3.0-or-later
+#
+# This file is part of Quotify - A simple CLI utility to shell quote the text
+# inputted into it.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/agpl.txt>.
+
+[package]
+name = "quotify"
+description = "A simple cli utility to shell quote the text inputed into it"
+version = "0.1.0"
+edition = "2021"
+license = "%INIT_SPDX_LICENSE_IDENTIFER"
+homepage = "%INIT_APPLICATION_HOMEPAGE"
+repository = "https://git.vhack.eu/soispha/tools/quotify"
+# TODO
+# categories = [""]
+# keywords = ["", ""]
+
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[dependencies]
+anyhow = "1.0.89"