about summary refs log tree commit diff stats
path: root/tests/by-name/nv/nvim-checkhealth/test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/by-name/nv/nvim-checkhealth/test.nix')
-rw-r--r--tests/by-name/nv/nvim-checkhealth/test.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/tests/by-name/nv/nvim-checkhealth/test.nix b/tests/by-name/nv/nvim-checkhealth/test.nix
new file mode 100644
index 00000000..d84a2627
--- /dev/null
+++ b/tests/by-name/nv/nvim-checkhealth/test.nix
@@ -0,0 +1,44 @@
+{
+  mkTest,
+  extraModules,
+  pkgs,
+  ...
+}:
+mkTest {
+  name = "nvim-checkhealth";
+
+  configuration = {
+    imports = [
+      ../../../../modules/by-name/nv/nvim/module.nix
+      ../../../../modules/by-name/ni/nixpkgs/module.nix
+    ];
+    config = {
+      soispha = {
+        nixpkgs = {
+          enable = true;
+          systemName = "x86_64-linux";
+        };
+        programs.nvim = {
+          enable = true;
+          shell = pkgs.zsh;
+        };
+      };
+      home-manager.users.soispha = {
+        home.packages = [
+          pkgs.bat
+          pkgs.ripgrep
+          pkgs.bat-extras.batgrep
+        ];
+        imports = [
+          extraModules.nixvim.homeManagerModule
+        ];
+      };
+    };
+  };
+
+  testData = {};
+
+  description = ./test.desc;
+
+  hash = "4927ff94c6e9fb0dcb25c8e3e30f3e489cab5bb0a054656776af19725308bfe1";
+}