about summary refs log tree commit diff stats
path: root/system/users/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/users/default.nix')
-rw-r--r--system/users/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/system/users/default.nix b/system/users/default.nix
index 97cf2ee0..f68c35d3 100644
--- a/system/users/default.nix
+++ b/system/users/default.nix
@@ -17,13 +17,16 @@ in {
     };
   };
   config = {
+    # I was told, that this solves some nasty problems:
+    programs.zsh.enable = true;
+
     users = {
       mutableUsers = false;
       users.soispha = {
         isNormalUser = true;
         home = "/home/soispha";
         createHome = true;
-        # shell = pkgs.zsh;
+        shell = pkgs.zsh;
         initialHashedPassword = cfg.hashedPassword;
         extraGroups = [
           "wheel"