about summary refs log tree commit diff stats
path: root/system/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/hardware/default.nix')
-rw-r--r--system/hardware/default.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/system/hardware/default.nix b/system/hardware/default.nix
deleted file mode 100644
index 77d3d3f0..00000000
--- a/system/hardware/default.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{
-  config,
-  pkgs,
-  ...
-}: {
-  hardware = {
-    keyboard.zsa.enable = false;
-    onlykey.enable = true;
-    opengl = {
-      enable = true;
-      extraPackages = builtins.attrValues {
-        inherit
-          (pkgs)
-          vaapiVdpau
-          libvdpau-va-gl
-          ;
-      };
-    };
-  };
-  services.udev.extraRules = ''
-            # Rules for Oryx web flashing and live training
-    KERNEL=="hidraw*", ATTRS{idVendor}=="16c0", MODE="0664", GROUP="plugdev"
-    KERNEL=="hidraw*", ATTRS{idVendor}=="3297", MODE="0664", GROUP="plugdev"
-
-    # Legacy rules for live training over webusb (Not needed for firmware v21+)
-      # Rule for all ZSA keyboards
-      SUBSYSTEM=="usb", ATTR{idVendor}=="3297", GROUP="plugdev"
-      # Rule for the Moonlander
-      SUBSYSTEM=="usb", ATTR{idVendor}=="3297", ATTR{idProduct}=="1969", GROUP="plugdev"
-      # Rule for the Ergodox EZ
-      SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="1307", GROUP="plugdev"
-      # Rule for the Planck EZ
-      SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="6060", GROUP="plugdev"
-
-    # Wally Flashing rules for the Ergodox EZ
-    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
-    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
-    SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
-    KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
-
-    # Wally Flashing rules for the Moonlander and Planck EZ
-    SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", \
-        MODE:="0666", \
-        SYMLINK+="stm32_dfu"
-  '';
-}