about summary refs log tree commit diff stats
path: root/system/filesystemLayouts/filesystemLayouts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/filesystemLayouts/filesystemLayouts.nix')
-rw-r--r--system/filesystemLayouts/filesystemLayouts.nix22
1 files changed, 6 insertions, 16 deletions
diff --git a/system/filesystemLayouts/filesystemLayouts.nix b/system/filesystemLayouts/filesystemLayouts.nix
index 5992179a..ad51bbb8 100644
--- a/system/filesystemLayouts/filesystemLayouts.nix
+++ b/system/filesystemLayouts/filesystemLayouts.nix
@@ -30,32 +30,22 @@ in {
       "/nix" = {
         device = cfg.mainDisk;
         fsType = "btrfs";
-        options = ["subvol=@nix" "compress-force=zstd:9"];
+        options = ["subvol=nix" "compress-force=zstd:15"];
       };
-      "/boot" = {
-        device = cfg.efiDisk;
-        fsType = "vfat";
-      };
-
-      "/srv/home" = {
+      "/srv" = {
         device = cfg.mainDisk;
         fsType = "btrfs";
-        options = ["subvol=@home" "compress-force=zstd:9"];
+        options = ["subvol=storage" "compress-force=zstd:15"];
       };
-      "/srv/nixos-config" = {
-        device = cfg.mainDisk;
-        fsType = "btrfs";
-        options = ["subvol=@nixos-config" "compress-force=zstd:9"];
+      "/boot" = {
+        device = cfg.efiDisk;
+        fsType = "vfat";
       };
 
       "/etc/nixos" = {
         device = "/srv/nix-config";
         options = ["bind"];
       };
-      "/home" = {
-        device = "/srv/home";
-        options = ["bind"];
-      };
     };
     swapDevices = [];
   };