about summary refs log tree commit diff stats
path: root/sys/users/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/users/default.nix')
-rw-r--r--sys/users/default.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/sys/users/default.nix b/sys/users/default.nix
deleted file mode 100644
index 46e489a3..00000000
--- a/sys/users/default.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}: let
-  cfg = config.soispha.users;
-in {
-  options.soispha.users = {
-    # enable = lib.mkEnableOption (lib.mdDoc "users");
-    hashedPassword = lib.mkOption {
-      type = lib.types.str;
-      example = lib.literalExpression "$y$jFT$ONrCqZIJKB7engmfA4orD/$0GO58/wV5wrYWj0cyONhyujZPjFmbT0XKtx2AvXLG0B";
-      default = "$y$jFT$ONrCqZIJKB7engmfA4orD/$0GO58/wV5wrYWj0cyONhyujZPjFmbT0XKtx2AvXLG0B";
-      description = lib.mdDoc "Hashed password for the user";
-    };
-  };
-
-  config = {
-    # I was told, that this solves some nasty problems:
-    programs.zsh.enable = true;
-
-    users = {
-      groups = {
-        plugdev.members = ["soispha"];
-      };
-      mutableUsers = false;
-      users.soispha = {
-        isNormalUser = true;
-        home = "/home/soispha";
-        createHome = true;
-        shell = pkgs.zsh;
-        initialHashedPassword = cfg.hashedPassword;
-        extraGroups = [
-          "plugdev" # although deprecated, this helps with old udev rules, that still use this group. TODO: check for an open issue
-          "wheel"
-        ];
-        uid = 1000;
-        openssh.authorizedKeys.keys = [
-          "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIME4ZVa+IoZf6T3U08JG93i6QIAJ4amm7mkBzO14JSkz"
-        ];
-      };
-    };
-  };
-}