about summary refs log tree commit diff stats
path: root/sys/svcs/xdg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/svcs/xdg/default.nix')
-rw-r--r--sys/svcs/xdg/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys/svcs/xdg/default.nix b/sys/svcs/xdg/default.nix
index 297928ce..1fe60c43 100644
--- a/sys/svcs/xdg/default.nix
+++ b/sys/svcs/xdg/default.nix
@@ -1,10 +1,15 @@
 {pkgs, ...}: {
+  services.dbus.enable = true;
   xdg = {
     portal = {
       enable = true;
       # TODO: only enable the below, when on river (or wlr based compositor)
       wlr.enable = true;
-      extraPortals = [pkgs.xdg-desktop-portal-wlr];
+      extraPortals = [
+        # NOTE: The next entry is supposedly needed for gtk based apps <2023-08-31>
+        pkgs.xdg-desktop-portal-gtk
+        pkgs.xdg-desktop-portal-wlr
+      ];
     };
   };
   # TODO: mime = {};