about summary refs log tree commit diff stats
path: root/sys/svcs/printing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/svcs/printing/default.nix')
-rw-r--r--sys/svcs/printing/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys/svcs/printing/default.nix b/sys/svcs/printing/default.nix
new file mode 100644
index 00000000..7b8a871e
--- /dev/null
+++ b/sys/svcs/printing/default.nix
@@ -0,0 +1,26 @@
+{pkgs, ...}: {
+  services.avahi = {
+    enable = true;
+    nssmdns = true;
+    openFirewall = true;
+  };
+  services.printing = {
+    enable = true;
+    startWhenNeeded = true;
+    webInterface = false;
+    drivers = [];
+  };
+  hardware = {
+    printers = {
+      ensurePrinters = [
+        {
+          name = "Brother";
+          description = "Brother DCP-9022CDW";
+          model = "everywhere";
+          deviceUri = "ipp://BRWACD1B84F4503.local:631/ipp/print";
+        }
+      ];
+      ensureDefaultPrinter = "Brother";
+    };
+  };
+}