about summary refs log tree commit diff stats
path: root/sys/options/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/options/default.nix')
-rw-r--r--sys/options/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys/options/default.nix b/sys/options/default.nix
new file mode 100644
index 00000000..72ebc4fb
--- /dev/null
+++ b/sys/options/default.nix
@@ -0,0 +1,26 @@
+{
+  lib,
+  config,
+  ...
+}: let
+  cfg = config.soispha;
+in {
+  options.soispha = {
+    laptop = {
+      enable = lib.mkEnableOption "Laptop improvemens";
+      backlight = lib.mkOption {
+        type = lib.types.str;
+        example = lib.mdDoc "intel_backlight";
+        description = lib.mdDoc "Which backlight to query for the screen brightness";
+      };
+    };
+    secrets = {
+      #enable = lib.mkEnableOption "Secrets through agenix";
+      enable = lib.mkOption {
+        type = lib.types.bool;
+        default = true;
+        description = lib.mdDoc "Enable secrets through agenix";
+      };
+    };
+  };
+}