about summary refs log tree commit diff stats
path: root/pkgs/sources/plgs-pkgs/update.sh
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sources/plgs-pkgs/update.sh')
-rwxr-xr-xpkgs/sources/plgs-pkgs/update.sh27
1 files changed, 0 insertions, 27 deletions
diff --git a/pkgs/sources/plgs-pkgs/update.sh b/pkgs/sources/plgs-pkgs/update.sh
deleted file mode 100755
index 6a0d3452..00000000
--- a/pkgs/sources/plgs-pkgs/update.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/usr/bin/env sh
-
-BASE_DIR="$(readlink -f "$(dirname "$0")/plugins")"
-
-# Fetch plugins
-cd "$BASE_DIR" || (echo "BUG: No '$BASE_DIR'" && exit 1)
-
-# Cleanup manifest
-sort -o "$BASE_DIR/manifest.txt" "$BASE_DIR/manifest.txt"
-sort -o "$BASE_DIR/blacklist.txt" "$BASE_DIR/blacklist.txt"
-## Remove all plugins, which are on the blacklist
-# The same file is read and written to
-# shellcheck disable=SC2005
-echo "$(comm -23 "$BASE_DIR/manifest.txt" "$BASE_DIR/blacklist.txt")" >"$BASE_DIR/manifest.txt"
-
-# Backup vim-plugins.nix
-mv "$BASE_DIR/default.nix" "$BASE_DIR/default.nix.bak"
-echo "{...} : {}" >"$BASE_DIR/default.nix"
-
-# Generate derivations for new plugins (this binary is provided by the dev-environment)
-update-vim-plugins cleanup "$BASE_DIR"
-
-# Restore vim-plugins.nix
-mv "$BASE_DIR/default.nix.bak" "$BASE_DIR/default.nix"
-
-# Update new plugins
-update-vim-plugins update "$BASE_DIR" --all