about summary refs log tree commit diff stats
path: root/modules/system/services/issue_file/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/services/issue_file/default.nix')
-rw-r--r--modules/system/services/issue_file/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/modules/system/services/issue_file/default.nix b/modules/system/services/issue_file/default.nix
new file mode 100644
index 00000000..930be1d9
--- /dev/null
+++ b/modules/system/services/issue_file/default.nix
@@ -0,0 +1,38 @@
+{config, ...}: {
+  environment.etc.issue = {
+    # Friendly greeting on the virtual consoles.
+    text = ''
+      [?25l[?7l                                           
+                ▗▄▄▄       ▗▄▄▄▄    ▄▄▄▖         
+                ▜███▙       ▜███▙  ▟███▛         
+                 ▜███▙       ▜███▙▟███▛          
+                  ▜███▙       ▜██████▛           
+           ▟█████████████████▙ ▜████▛     ▟▙     
+          ▟███████████████████▙ ▜███▙    ▟██▙    
+                 ▄▄▄▄▖           ▜███▙  ▟███▛    
+                ▟███▛             ▜██▛ ▟███▛     
+               ▟███▛               ▜▛ ▟███▛      
+      ▟███████████▛                  ▟██████████▙
+      ▜██████████▛                  ▟███████████▛
+            ▟███▛ ▟▙               ▟███▛         
+           ▟███▛ ▟██▙             ▟███▛          
+          ▟███▛  ▜███▙           ▝▀▀▀▀           
+          ▜██▛    ▜███▙ ▜██████████████████▛     
+           ▜▛     ▟████▙ ▜████████████████▛      
+                 ▟██████▙       ▜███▙            
+                ▟███▛▜███▙       ▜███▙           
+               ▟███▛  ▜███▙       ▜███▙          
+               ▝▀▀▀    ▀▀▀▀▘       ▀▀▀▘          
+                                                 
+       NixOS ${config.system.nixos.label} 
+        --------------
+      
+        date: \d
+        time: \t
+        ipv4: \4
+        ipv6: \6
+        tty: \l
+      
+    '';
+  };
+}