about summary refs log tree commit diff stats
path: root/modules/home/conf/beets/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/conf/beets/default.nix')
-rw-r--r--modules/home/conf/beets/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/home/conf/beets/default.nix b/modules/home/conf/beets/default.nix
index 643538e7..ac42d5b9 100644
--- a/modules/home/conf/beets/default.nix
+++ b/modules/home/conf/beets/default.nix
@@ -1,5 +1,6 @@
 {
   pkgs,
+  lib,
   config,
   ...
 }: {
@@ -228,4 +229,13 @@
       host = config.home.sessionVariables.MPD_HOST;
     };
   };
+
+  # Use the json formatter instead of the YAML one, as the YAML formatter mangles the
+  # longer python inline strings.
+  # YAML is a superset of JSON.
+  xdg.configFile."beets/config.yaml".source =
+    lib.mkForce
+    ((pkgs.formats.json {}).generate
+      "beets-config"
+      config.programs.beets.settings);
 }