about summary refs log tree commit diff stats
path: root/modules/home.legacy/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/pkgs/default.nix')
-rw-r--r--modules/home.legacy/pkgs/default.nix16
1 files changed, 5 insertions, 11 deletions
diff --git a/modules/home.legacy/pkgs/default.nix b/modules/home.legacy/pkgs/default.nix
index ad77c5fb..2018805f 100644
--- a/modules/home.legacy/pkgs/default.nix
+++ b/modules/home.legacy/pkgs/default.nix
@@ -5,14 +5,8 @@
   nixosConfig,
   ...
 }:
+# TODO: Remove this whole file, and move each pkgs to a separate module. <2024-11-16>
 with pkgs; let
-  onlyShare = drv:
-    runCommand "${drv.name}-only-share" {} ''
-      mkdir -p $out
-      ln -s ${drv}/share $out/share
-    '';
-  mpc-cli-man = onlyShare mpc-cli;
-
   Gui = {
     Terminals = [
       # foot # wayland native terminal
@@ -126,9 +120,10 @@ with pkgs; let
 
       Listen = [
         spodi # Wrapper around `spotdl`.
-        ncmpc # mpd player client
-        mpc-cli-man # a cli mpd client (added via a wrapper script)
-        mpc # Wrapper around `mpc` that allows the usage of `mpc-{rm,lyrics,searchadd}` without the `-`
+        sort_song # Sorts songs in the current directory.
+
+        mpp # Wrapper around `mpc` that allows the usage of `mpc-{beetsrm,lyrics,searchadd}` (below) without the `-`
+
         # Removes the currently playing song from the disk and storage
         (mpc-beetrm.override {
           beets = config.programs.beets.package;
@@ -141,7 +136,6 @@ with pkgs; let
         (mpc-lyrics.override {
           mpd_music_dir = config.services.mpd.musicDirectory;
         })
-        sort_song # Sorts songs in the current directory.
       ];
     };