about summary refs log tree commit diff stats
path: root/modules/home.legacy/files/wallpaper/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/files/wallpaper/default.nix')
-rw-r--r--modules/home.legacy/files/wallpaper/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/home.legacy/files/wallpaper/default.nix b/modules/home.legacy/files/wallpaper/default.nix
new file mode 100644
index 00000000..119df225
--- /dev/null
+++ b/modules/home.legacy/files/wallpaper/default.nix
@@ -0,0 +1,14 @@
+{config, ...}: {
+  home = {
+    sessionVariables = {
+      WALLPAPER = "${config.home.homeDirectory}/media/pictures/wallpaper";
+    };
+
+    file = {
+      wallpaper = {
+        source = ./abstract-nord.png;
+        target = "media/pictures/wallpaper";
+      };
+    };
+  };
+}