about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/ssh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/ssh/default.nix')
-rw-r--r--modules/home.legacy/conf/ssh/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/ssh/default.nix b/modules/home.legacy/conf/ssh/default.nix
new file mode 100644
index 00000000..de9b0d90
--- /dev/null
+++ b/modules/home.legacy/conf/ssh/default.nix
@@ -0,0 +1,16 @@
+{config, ...}: {
+  programs.ssh = {
+    enable = true;
+    compression = true;
+    hashKnownHosts = false;
+    serverAliveInterval = 240;
+    userKnownHostsFile = "${config.xdg.dataHome}/ssh/known_hosts";
+
+    matchBlocks = {
+      "codeberg.org" = {
+        # TODO: Remove this once they fix their ipv6 config
+        addressFamily = "inet";
+      };
+    };
+  };
+}