about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/todo-comments/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/todo-comments/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/todo-comments/default.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/todo-comments/default.nix b/modules/home.legacy/conf/nvim/plgs/todo-comments/default.nix
new file mode 100644
index 00000000..e33f961b
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/todo-comments/default.nix
@@ -0,0 +1,51 @@
+{...}: {
+  programs.nixvim.plugins.todo-comments = {
+    enable = true;
+    settings = {
+      guiStyle = {
+        fg = "BOLD";
+        bg = "NONE";
+      };
+      highlight = {
+        keyword = "wide_fg";
+      };
+      keywords = {
+        /*
+        # Defaults:
+        FIX = {
+          icon = " "; # Icon used for the sign, and in search results.
+          color = "error"; # Can be a hex color, or a named color.
+          alt = ["FIXME" "BUG" "FIXIT" "ISSUE"]; # A set of other keywords that all map to this FIX keywords.
+        };
+        TODO = {
+          icon = " ";
+          color = "info";
+        };
+        HACK = {
+          icon = " ";
+          color = "warning";
+        };
+        WARN = {
+          icon = " ";
+          color = "warning";
+          alt = ["WARNING" "XXX"];
+        };
+        PERF = {
+          icon = "󰅒 ";
+          alt = ["OPTIM" "PERFORMANCE" "OPTIMIZE"];
+        };
+        NOTE = {
+          icon = "󰍨 ";
+          color = "hint";
+          alt = ["INFO"];
+        };
+        TEST = {
+          icon = "⏲ ";
+          color = "test";
+          alt = ["TESTING" "PASSED" "FAILED"];
+        };
+        */
+      };
+    };
+  };
+}