about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/telescope/extensions/bibtex/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/telescope/extensions/bibtex/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/telescope/extensions/bibtex/default.nix b/modules/home.legacy/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
new file mode 100644
index 00000000..6f3cc2ea
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
@@ -0,0 +1,17 @@
+{pkgs, ...}: {
+  # WARNING: This is only activated in tex files via the ftplugin.
+  programs.nixvim = {
+    extraPlugins = [
+      pkgs.vimExtraPlugins.telescope-bibtex-nvim
+    ];
+    keymaps = [
+      {
+        key = "<space>ib";
+        # This is registered in the ftplugin file, so we set this to null here
+        action = "<Nop>";
+        mode = "n";
+        options.desc = "[i]nsert a [b]atex citation";
+      }
+    ];
+  };
+}