about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/telescope/defaults/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/telescope/defaults/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/telescope/defaults/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/telescope/defaults/default.nix b/modules/home.legacy/conf/nvim/plgs/telescope/defaults/default.nix
new file mode 100644
index 00000000..933089ef
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/telescope/defaults/default.nix
@@ -0,0 +1,30 @@
+{...}: {
+  programs.nixvim.plugins.telescope.settings.defaults = {
+    mappings = let
+      insert_and_normal_mappings = {
+        # map actions.which_key to <c-h> (default: <c-/>)
+        # actions.which_key shows the mappings for your picker,
+        # e.g. git_{create, delete, ...}_branch for the git_branches picker
+        "<C-h>" = "which_key";
+      };
+    in {
+      i =
+        insert_and_normal_mappings;
+      n =
+        {
+          "t" = "move_selection_next";
+          "n" = "move_selection_previous";
+          "<Space>" = "toggle_all";
+
+          "<C-d>" = "preview_scrolling_up";
+          "<C-u>" = "preview_scrolling_down";
+          "<Left>" = "preview_scrolling_left";
+          "<Right>" = "preview_scrolling_right";
+
+          "<Esc>" = "close";
+          "q" = "close";
+        }
+        // insert_and_normal_mappings;
+    };
+  };
+}