about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix b/modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix
new file mode 100644
index 00000000..ed0e57c3
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix
@@ -0,0 +1,54 @@
+{config, ...}: {
+  programs.nixvim.plugins.cmp = let
+    neorg_source =
+      if config.programs.nixvim.plugins.neorg.modules."core.completion".config.engine == "nvim-cmp"
+      then [{name = "neorg";}]
+      else [];
+  in {
+    /*
+    TODO: integrate this:
+    ```lua
+      enabled = {
+      function()
+          -- disable completion in comments
+          local context = require 'cmp.config.context'
+          -- keep command mode completion enabled when cursor is in a comment
+          -- te
+          if vim.api.nvim_get_mode().mode == 'c' then
+              return true
+          else
+              return not context.in_treesitter_capture("comment")
+                  and not context.in_syntax_group("Comment")
+          end
+      end
+      },
+    ```
+    */
+    enable = true;
+    autoEnableSources = true;
+    settings = {
+      mapping = {
+        # TODO: add support for desc and which key here
+        "<C-d>" = "cmp.mapping.scroll_docs(-4)"; # desc = "Scroll up by four lines"
+        "<C-f>" = "cmp.mapping.scroll_docs(4)"; # desc = "Scroll down by four lines"
+        "HH" = "cmp.mapping.complete()"; # desc = "Confirm snipped"
+      };
+
+      snippet.expand = "function(args) require('luasnip').lsp_expand(args.body) end";
+
+      sources =
+        [
+          {name = "nvim_lsp";}
+          {name = "luasnip";}
+          {name = "path";}
+          {name = "git";} # TODO: I might want to add config to allow all issues/prs <2023-10-16>
+          # {name = "convertionalcommits";} # TODO: Useless without commitlint [https://commitlint.js.org/] <2023-10-16>
+          # {name = "rg";} # TODO: This might really RIP-grep my system <2023-10-16>
+          # {name = "buffer";}
+          # {name = "digraphs";}
+          {name = "calc";}
+        ]
+        ++ neorg_source;
+    };
+  };
+}