about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/neorg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/neorg/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/neorg/default.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/neorg/default.nix b/modules/home.legacy/conf/nvim/plgs/neorg/default.nix
new file mode 100644
index 00000000..7d61ce09
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/neorg/default.nix
@@ -0,0 +1,57 @@
+{pkgsStable, ...}: {
+  programs.nixvim.plugins.neorg = {
+    package = pkgsStable.vimPlugins.neorg;
+    enable = true;
+    lazyLoading = true;
+
+    modules = {
+      "core.defaults" = {
+        __empty = null;
+      };
+      "core.esupports.metagen".config = {
+        type = "auto";
+      };
+      "core.journal".config = {
+        workspace = "journal";
+      };
+      "core.keybinds".config = {
+        hook = {
+          __raw = ''
+            function(keybinds)
+                -- remap the looking glas to the same key, femaco is also mapped to.
+                keybinds.remap_event("norg", "n", "<space>cc", "core.looking-glass.magnify-code-block")
+
+                keybinds.remap_event("norg", "n", "<C-s>", "core.integrations.telescope.find_linkable")
+                keybinds.remap_event("norg", "i", "<C-i>", "core.integrations.telescope.insert_link")
+            end,
+          '';
+        };
+      };
+      "core.completion".config = {
+        engine = "nvim-cmp";
+      };
+      "core.concealer".config = {
+        __empty = null;
+      };
+      "core.dirman".config = {
+        workspaces = {
+          general = "~/repos/notes/general";
+          journal = "~/repos/notes/journal";
+          projects = "~/repos/notes/projects";
+        };
+      };
+      "core.export".config = {
+        __empty = null;
+      };
+      "core.integrations.telescope".config = {
+        __empty = null;
+      };
+
+      # TODO: Add this when the nvim version in nixpkgs is >= 0.10 <2023-08-29>
+      #
+      # "core.ui.calendar".config = {
+      #   __empty = null;
+      # };
+    };
+  };
+}