about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/ltex_extra/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/ltex_extra/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/ltex_extra/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/ltex_extra/default.nix b/modules/home.legacy/conf/nvim/plgs/ltex_extra/default.nix
new file mode 100644
index 00000000..af78c7a5
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/ltex_extra/default.nix
@@ -0,0 +1,9 @@
+{pkgs, ...}: {
+  programs.nixvim = {
+    # TODO: package ltex_extra though a module
+    extraPlugins = [
+      pkgs.vimPlugins.ltex_extra-nvim
+    ];
+    plugins.lsp.servers.ltex.onAttach.function = builtins.readFile ./lua/ltex_extra.lua;
+  };
+}