about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/lsp/servers/servers/openscad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/lsp/servers/servers/openscad.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/lsp/servers/servers/openscad.nix17
1 files changed, 0 insertions, 17 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/lsp/servers/servers/openscad.nix b/modules/home.legacy/conf/nvim/plgs/lsp/servers/servers/openscad.nix
deleted file mode 100644
index a0221cc4..00000000
--- a/modules/home.legacy/conf/nvim/plgs/lsp/servers/servers/openscad.nix
+++ /dev/null
@@ -1,17 +0,0 @@
-{pkgs, ...}: {
-  programs.nixvim = {
-    extraConfigLuaPost =
-      /*
-      lua
-      */
-      ''
-        require('lspconfig').openscad_lsp.setup{
-          cmd = {"openscad-lsp", "--stdio", "--fmt-style", "WebKit"},
-        }
-      '';
-    extraPackages = with pkgs; [
-      openscad-lsp
-      clang-tools # Need to satisfy `clang-format` (which is used by openscad-lsp)
-    ];
-  };
-}