about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/lsp/keymaps/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/lsp/keymaps/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/lsp/keymaps/default.nix70
1 files changed, 0 insertions, 70 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/lsp/keymaps/default.nix b/modules/home.legacy/conf/nvim/plgs/lsp/keymaps/default.nix
deleted file mode 100644
index b1276639..00000000
--- a/modules/home.legacy/conf/nvim/plgs/lsp/keymaps/default.nix
+++ /dev/null
@@ -1,70 +0,0 @@
-{...}: {
-  programs.nixvim = {
-    plugins.lsp.keymaps = {
-      diagnostic = {
-        "N" = {
-          action = "goto_prev";
-          desc = "go to previous diagnostic message";
-        };
-        "T" = {
-          action = "goto_next";
-          desc = "go to next diagnostic message";
-        };
-        "<space>e" = {
-          action = "open_float";
-          desc = "open float for the symbol";
-        };
-        "<space>gq" = {
-          action = "setloclist";
-          desc = "add buffer diagnostic to the location list (quick-fix)";
-        };
-      };
-      lspBuf = {
-        "<space>gD" = {
-          action = "declaration";
-          desc = "[G]o to [d]eclaration";
-        };
-        "<space>hi" = {
-          action = "hover";
-          desc = "Display [h]over [i]nformation";
-        };
-        "<space>sh" = {
-          action = "signature_help";
-          desc = "Display [s]ignature [h]elp";
-        };
-        "<space>wa" = {
-          action = "add_workspace_folder";
-          desc = "[W]orkspace folder [a]dd";
-        };
-        "<space>wr" = {
-          action = "remove_workspace_folder";
-          desc = "[W]orkspace folder [r]emove";
-        };
-        "<space>rn" = {
-          action = "rename";
-          desc = "[R]e[n]ame the item under the cursor";
-        };
-        "<space>ca" = {
-          action = "code_action";
-          desc = "Open the [c]ode [a]ction menu";
-        };
-      };
-    };
-    keymaps = [
-      {
-        key = "<space>f";
-        action.__raw = "function() vim.lsp.buf.format { async = true } end";
-        options.desc = "[F]ormat the current buffer (asynchronously)";
-      }
-      {
-        key = "<space>wl";
-        action.__raw = ''
-          function()
-            print(vim.inspect(vim.lsp.buf.list_workspace_folders()))
-          end
-        '';
-        options.desc = "[W]orkspace folders [l]ist";
-      }
-    ];
-  };
-}