about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/lsp-progress-nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/lsp-progress-nvim/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/lsp-progress-nvim/default.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/lsp-progress-nvim/default.nix b/modules/home.legacy/conf/nvim/plgs/lsp-progress-nvim/default.nix
deleted file mode 100644
index 6602ceb6..00000000
--- a/modules/home.legacy/conf/nvim/plgs/lsp-progress-nvim/default.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{
-  lib,
-  pkgs,
-  ...
-}: {
-  programs.nixvim = {
-    # TODO: package lsp-progress-nvim though a module
-    extraConfigLuaPost = ''
-      ${lib.strings.fileContents ./lua/lsp-progress-nvim.lua}
-    '';
-    extraPlugins = [
-      pkgs.vimExtraPlugins.lsp-progress-nvim
-    ];
-
-    # Status line setup
-    autoGroups.lsp_refresh.clear = true;
-    autoCmd = [
-      {
-        event = ["User LspProgressStatusUpdated"];
-        pattern = ["*"];
-        callback =
-          /*
-          lua
-          */
-          {
-            __raw = ''
-              require("lualine").refresh
-            '';
-          };
-        group = "lsp_refresh";
-        description = "Refresh the statusbar when the lsp status was updated.";
-      }
-    ];
-    plugins.lualine = let
-      get_lsp_progress = {
-        __raw =
-          /*
-          lua
-          */
-          ''
-            require('lsp-progress').progress
-          '';
-      };
-    in {
-      sections = {
-        lualine_c = [{name = get_lsp_progress;}];
-      };
-    };
-  };
-}