about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix b/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix
new file mode 100644
index 00000000..11ad2807
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix
@@ -0,0 +1,18 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO: package lf-nvim though a module
+    # FIXME: change the nvim path, when I change the path with lf
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/lf-nvim.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimExtraPlugins.lf-nvim
+
+      pkgs.vimPlugins.toggleterm-nvim # required by lf-nvim
+    ];
+  };
+}