about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/flatten-nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/flatten-nvim/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/flatten-nvim/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/flatten-nvim/default.nix b/modules/home.legacy/conf/nvim/plgs/flatten-nvim/default.nix
new file mode 100644
index 00000000..cd6f8bcc
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/flatten-nvim/default.nix
@@ -0,0 +1,20 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO: package flatten-nvim though a module
+
+    extraConfigLuaPre = ''
+      ${lib.strings.fileContents ./lua/flatten-nvim.lua}
+      if os.getenv("NVIM") ~= nil then
+        -- Avoid loading plugins because the host will take control of the instance anyways
+        return
+      end
+    '';
+    extraPlugins = [
+      pkgs.vimPlugins.flatten-nvim
+    ];
+  };
+}