about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/debugprint/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/debugprint/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/debugprint/default.nix70
1 files changed, 70 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/debugprint/default.nix b/modules/home.legacy/conf/nvim/plgs/debugprint/default.nix
new file mode 100644
index 00000000..3c591e9f
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/debugprint/default.nix
@@ -0,0 +1,70 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO: package debugprint though a module
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/debugprint.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimExtraPlugins.debugprint-nvim
+    ];
+
+    keymaps = [
+      {
+        key = "g?v";
+        mode = ["v" "n"];
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint({variable = true;});
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'variable' debug line below the current line
+        '';
+      }
+      {
+        key = "g?V";
+        mode = ["v" "n"];
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint({above = true; variable = true;}) ;
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'variable' debug line above the current line
+        '';
+      }
+      {
+        key = "g?p";
+        mode = "n";
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint();
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'plain' debug line below the current line
+        '';
+      }
+      {
+        key = "g?P";
+        mode = "n";
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint({above = true;});
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'plain' debug line above the current line
+        '';
+      }
+    ];
+  };
+}